Back to overview
Maintenance

Limited support during the Easter holidays

Apr 15 at 12:00am EEST  –  Apr 26 at 12:00pm EEST
Affected services
Support Services

Resolved
Apr 20 at 10:21pm EEST

We are extending our holiday period by one more week for all mentioned support services. Happy Easter!

Created
Apr 15 at 12:00am EEST

Our support during from the 15th April 2022 to 27th April 2022 will be limited.

  • Live Chat and Tickets: Expect delays.
  • Technicians: Our technicians will be on site and ready to respond to any incidents or downtime.
  • Billing, Legal & Admin: Our staff team will be able to assist you with inquiries after they return to their offices at the 20th of April.

Kind reminder that our Discord server community is always available to help you with questions & code help. Not a member yet? Join here -> https://discord.gg/hosting